Buffer Overflow Affecting liblouis package, versions <3.12.0-3ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.36% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBLOUIS-3363394
  • published17 Mar 2023
  • disclosed16 Mar 2023

Introduced: 16 Mar 2023

CVE-2023-26767  (opens in a new tab)
CWE-120  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 liblouis to version 3.12.0-3ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream liblouis package and not the liblouis package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Buffer Overflow vulnerability found in Liblouis v.3.24.0 allows a remote attacker to cause a denial of service via the lou_logFile function at logginc.c endpoint.

CVSS Base Scores

version 3.1