Memory Leak Affecting libmatio package, versions <1.5.17-3ubuntu0.1~esm2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.7% (52nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBMATIO-2806565
  • published21 Mar 2026
  • disclosed2 May 2022

Introduced: 2 May 2022

CVE-2022-1515  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 libmatio to version 1.5.17-3ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libmatio package and not the libmatio package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A memory leak was discovered in matio 1.5.21 and earlier in Mat_VarReadNextInfo5() in mat5.c via a crafted file. This issue can potentially result in DoS.

CVSS Base Scores

version 3.1