CVE-2021-47154 Affecting libnet-cidr-lite-perl package, versions <0.21-2ubuntu0.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.49% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBNETCIDRLITEPERL-6467218
  • published25 Mar 2024
  • disclosed18 Mar 2024

Introduced: 18 Mar 2024

CVE-2021-47154  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 libnet-cidr-lite-perl to version 0.21-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnet-cidr-lite-perl package and not the libnet-cidr-lite-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The Net::CIDR::Lite module before 0.22 for Perl does not properly consider extraneous zero characters at the beginning of an IP address string, which (in some situations) allows attackers to bypass access control that is based on IP addresses.

CVSS Base Scores

version 3.1