CVE-2024-56830 Affecting libnet-easytcp-perl package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.39% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBNETEASYTCPPERL-8601580
  • published25 Oct 2026
  • disclosed2 Jan 2025

Introduced: 2 Jan 2025

CVE-2024-56830  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.04 libnet-easytcp-perl.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libnet-easytcp-perl package and not the libnet-easytcp-perl package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The Net::EasyTCP package 0.15 through 0.26 for Perl uses Perl's builtin rand() if no strong randomization module is present.