Improper Input Validation Affecting libraw package, versions <0.19.5-1ubuntu1.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.67% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBRAW-1139150
  • published5 Nov 2022
  • disclosed2 Jul 2020

Introduced: 2 Jul 2020

CVE-2020-15503  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 libraw to version 0.19.5-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libraw package and not the libraw package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

LibRaw before 0.20-RC1 lacks a thumbnail size range check. This affects decoders/unpack_thumb.cpp, postprocessing/mem_image.cpp, and utils/thumb_utils.cpp. For example, malloc(sizeof(libraw_processed_image_t)+T.tlength) occurs without validating T.tlength.

References

CVSS Base Scores

version 3.1