Out-of-bounds Read Affecting libsepol package, versions <3.0-1ubuntu0.1


Severity

Recommended
0.0
low
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.48% (40th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-LIBSEPOL-1315888
  • published3 Jul 2021
  • disclosed1 Jul 2021

Introduced: 1 Jul 2021

CVE-2021-36087  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 libsepol to version 3.0-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libsepol package and not the libsepol package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The CIL compiler in SELinux 3.2 has a heap-based buffer over-read in ebitmap_match_any (called indirectly from cil_check_neverallow). This occurs because there is sometimes a lack of checks for invalid statements in an optional block.

CVSS Base Scores

version 3.1