Improper Restriction of Excessive Authentication Attempts Affecting mailman package, versions <1:2.1.29-1ubuntu3.1+esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.15% (65th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-MAILMAN-1922406
  • published19 Aug 2025
  • disclosed12 Nov 2021

Introduced: 12 Nov 2021

CVE-2021-43332  (opens in a new tab)
CWE-307  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 mailman to version 1:2.1.29-1ubuntu3.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mailman package and not the mailman package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In GNU Mailman before 2.1.36, the CSRF token for the Cgi/admindb.py admindb page contains an encrypted version of the list admin password. This could potentially be cracked by a moderator via an offline brute-force attack.

CVSS Base Scores

version 3.1