Cross-site Scripting (XSS) Affecting mailman package, versions <1:2.1.29-1ubuntu3.1+esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.38% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-MAILMAN-1922412
  • published19 Aug 2025
  • disclosed12 Nov 2021

Introduced: 12 Nov 2021

CVE-2021-43331  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 mailman to version 1:2.1.29-1ubuntu3.1+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mailman package and not the mailman package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In GNU Mailman before 2.1.36, a crafted URL to the Cgi/options.py user options page can execute arbitrary JavaScript for XSS.

CVSS Base Scores

version 3.1