Out-of-bounds Write Affecting musl package, versions <1.1.24-1ubuntu0.1~esm1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.65% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-MUSL-1132870
  • published19 Aug 2025
  • disclosed24 Nov 2020

Introduced: 24 Nov 2020

CVE-2020-28928  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 musl to version 1.1.24-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream musl package and not the musl package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In musl libc through 1.2.1, wcsnrtombs mishandles particular combinations of destination buffer size and source character limit, as demonstrated by an invalid write access (buffer overflow).

References

CVSS Base Scores

version 3.1