CVE-2005-1513 Affecting netqmail package, versions <1.06-6.2~deb10u1build0.20.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
10.79% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-NETQMAIL-1014032
  • published29 Sept 2020
  • disclosed11 May 2005

Introduced: 11 May 2005

CVE-2005-1513  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 netqmail to version 1.06-6.2~deb10u1build0.20.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream netqmail package and not the netqmail package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Integer overflow in the stralloc_readyplus function in qmail, when running on 64 bit platforms with a large amount of virtual memory, allows remote attackers to cause a denial of service and possibly execute arbitrary code via a large SMTP request.

CVSS Base Scores

version 3.1