Out-of-bounds Write Affecting nettle Open this link in a new tab package, versions <3.5.1+really3.5.1-2ubuntu0.1
Do your applications use this vulnerable package?
In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.Test your applications
7 Apr 2021
5 Apr 2021
How to fix?
nettle to version 3.5.1+really3.5.1-2ubuntu0.1 or higher.
Note: Versions mentioned in the description apply to the upstream
How to fix? for
Ubuntu:20.04 relevant versions.
A flaw was found in Nettle in versions before 3.7.2, where several Nettle signature verification functions (GOST DSA, EDDSA & ECDSA) result in the Elliptic Curve Cryptography point (ECC) multiply function being called with out-of-range scalers, possibly resulting in incorrect results. This flaw allows an attacker to force an invalid signature, causing an assertion failure or possible validation. The highest threat to this vulnerability is to confidentiality, integrity, as well as system availability.