Inefficient Regular Expression Complexity Affecting nltk package, versions <3.4.5-2ubuntu0.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.57% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-NLTK-2330149
  • published19 Mar 2025
  • disclosed4 Jan 2022

Introduced: 4 Jan 2022

CVE-2021-3842  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 nltk to version 3.4.5-2ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nltk package and not the nltk package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

nltk is vulnerable to Inefficient Regular Expression Complexity

CVSS Base Scores

version 3.1