Improper Verification of Cryptographic Signature Affecting node-browserify-sign package, versions <4.0.4-2ubuntu0.20.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.56% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-NODEBROWSERIFYSIGN-6036954
  • published28 May 2024
  • disclosed26 Oct 2023

Introduced: 26 Oct 2023

CVE-2023-46234  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 node-browserify-sign to version 4.0.4-2ubuntu0.20.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-browserify-sign package and not the node-browserify-sign package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

browserify-sign is a package to duplicate the functionality of node's crypto public key functions, much of this is based on Fedor Indutny's work on indutny/tls.js. An upper bound check issue in dsaVerify function allows an attacker to construct signatures that can be successfully verified by any public key, thus leading to a signature forgery attack. All places in this project that involve DSA verification of user-input signatures will be affected by this vulnerability. This issue has been patched in version 4.2.2.

CVSS Base Scores

version 3.1