Use After Free Affecting nvidia-graphics-drivers-570 package, versions <570.195.03-0ubuntu0.20.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.24% (15th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-NVIDIAGRAPHICSDRIVERS570-13570266
  • published25 Nov 2025
  • disclosed10 Oct 2025

Introduced: 10 Oct 2025

CVE-2025-23280  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 nvidia-graphics-drivers-570 to version 570.195.03-0ubuntu0.20.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-graphics-drivers-570 package and not the nvidia-graphics-drivers-570 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

NVIDIA Display Driver for Linux contains a vulnerability where an attacker could cause a use-after-free. A successful exploit of this vulnerability might lead to code execution, escalation of privileges, data tampering, denial of service, and information disclosure.