Improper Authentication Affecting pam package, versions <1.3.1-5ubuntu4.4


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.58% (76th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PAM-3033891
  • published27 Sept 2022
  • disclosed19 Sept 2022

Introduced: 19 Sep 2022

CVE-2022-28321  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 pam to version 1.3.1-5ubuntu4.4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam package and not the pam package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The Linux-PAM package before 1.5.2-6.1 for openSUSE Tumbleweed allows authentication bypass for SSH logins. The pam_access.so module doesn't correctly restrict login if a user tries to connect from an IP address that is not resolvable via DNS. In such conditions, a user with denied access to a machine can still get access. NOTE: the relevance of this issue is largely limited to openSUSE Tumbleweed and openSUSE Factory; it does not affect Linux-PAM upstream.

CVSS Base Scores

version 3.1