CVE-2026-109618 Affecting php7.4 package, versions <7.4.3-4ubuntu2.29+esm5


Severity

Recommended
0.0
critical
0
10

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Attacked
EPSS
100% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PHP74-21373928
  • published22 Oct 2026
  • disclosed21 Oct 2026

Introduced: 21 Oct 2026

NewCVE-2026-109618  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 php7.4 to version 7.4.3-4ubuntu2.29+esm5 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php7.4 package and not the php7.4 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

PHP uses longjmp() for out-of-memory (OOM) errors to exit the current context and abort handling of the request. Some contexts may not properly account for this scenario and leave request memory in an uninitialized state before performing an allocation. The subsequent request cleanup procedure may read or branch on this memory. Multiple OOM strategies can consistently trigger this condition and lead to remote code execution (RCE).

CVSS Base Scores

version 3.1