CVE-2022-24303 Affecting pillow-python2 package, versions <6.2.1-3ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.69% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PILLOWPYTHON2-2401134
  • published15 Feb 2022
  • disclosed28 Mar 2022

Introduced: 15 Feb 2022

CVE-2022-24303  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 pillow-python2 to version 6.2.1-3ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pillow-python2 package and not the pillow-python2 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Pillow before 9.0.1 allows attackers to delete files because spaces in temporary pathnames are mishandled.

CVSS Base Scores

version 3.1