Memory Leak Affecting privoxy package, versions <3.0.28-2ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.36% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PRIVOXY-2315066
  • published10 Dec 2021
  • disclosed23 Dec 2021

Introduced: 10 Dec 2021

CVE-2021-44540  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 privoxy to version 3.0.28-2ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A vulnerability was found in Privoxy which was fixed in get_url_spec_param() by freeing memory of compiled pattern spec before bailing.

CVSS Base Scores

version 3.1