HTTP Request Smuggling Affecting puma package, versions <3.12.4-1ubuntu2+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
4.09% (90th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PUMA-1147775
  • published1 Mar 2023
  • disclosed22 May 2020

Introduced: 22 May 2020

CVE-2020-11076  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 puma to version 3.12.4-1ubuntu2+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puma package and not the puma package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4.

CVSS Base Scores

version 3.1