HTTP Request Smuggling Affecting puma package, versions <3.12.4-1ubuntu2+esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.96% (57th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PUMA-6148034
  • published8 Mar 2024
  • disclosed8 Jan 2024

Introduced: 8 Jan 2024

CVE-2024-21647  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 puma to version 3.12.4-1ubuntu2+esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puma package and not the puma package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.

CVSS Base Scores

version 3.1