HTTP Request Smuggling Affecting puma package, versions <3.12.4-1ubuntu2+esm2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.64% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PUMA-8063622
  • published26 Sept 2024
  • disclosed19 Sept 2024

Introduced: 19 Sep 2024

CVE-2024-45614  (opens in a new tab)
CWE-444  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 puma to version 3.12.4-1ubuntu2+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puma package and not the puma package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Puma is a Ruby/Rack web server built for parallelism. In affected versions clients could clobber values set by intermediate proxies (such as X-Forwarded-For) by providing a underscore version of the same header (X-Forwarded_For). Any users relying on proxy set variables is affected. v6.4.3/v5.6.9 now discards any headers using underscores if the non-underscore version also exists. Effectively, allowing the proxy defined headers to always win. Users are advised to upgrade. Nginx has a underscores_in_headers configuration variable to discard these headers at the proxy level as a mitigation. Any users that are implicitly trusting the proxy defined headers for security should immediately cease doing so until upgraded to the fixed versions.

CVSS Base Scores

version 3.1