Incorrect Authorization Affecting python-scrapy package, versions <1.7.3-1ubuntu0.1~esm1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.23% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-PYTHONSCRAPY-2414989
  • published18 Apr 2025
  • disclosed2 Mar 2022

Introduced: 2 Mar 2022

CVE-2022-0577  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 python-scrapy to version 1.7.3-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-scrapy package and not the python-scrapy package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Exposure of Sensitive Information to an Unauthorized Actor in GitHub repository scrapy/scrapy prior to 2.6.1.

CVSS Base Scores

version 3.1