Cleartext Storage of Sensitive Information Affecting rabbitmq-server package, versions <3.8.3-0ubuntu0.3+esm2


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.17% (6th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-RABBITMQSERVER-20260273
  • published18 Oct 2026
  • disclosed25 Sept 2026

Introduced: 25 Sep 2026

CVE-2026-67236  (opens in a new tab)
CWE-312  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 rabbitmq-server to version 3.8.3-0ubuntu0.3+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rabbitmq-server package and not the rabbitmq-server package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

RabbitMQ is a messaging and streaming broker. From 4.2.0 until 4.2.8 and 4.3.2, a successful POST /login caused is_authorized/2 to set an auth cookie containing base64-encoded username:password credentials without HttpOnly, Secure, SameSite, or expiration protections. Because base64 is encoding rather than encryption, an attacker with same-origin cross-site scripting, an HTTP-readable network position, or local access to the browser cookie store could recover the actual login credentials; older browsers that treated an absent SameSite attribute as None also sent the cookie cross-site. This issue is fixed in versions 4.2.8 and 4.3.2.

CVSS Base Scores

version 3.1