Cross-site Scripting (XSS) Affecting ruby-gon package, versions *


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.38% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-RUBYGON-1014618
  • published1 Oct 2020
  • disclosed23 Sept 2020

Introduced: 23 Sep 2020

CVE-2020-25739  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.04 ruby-gon.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-gon package and not the ruby-gon package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

An issue was discovered in the gon gem before gon-6.4.0 for Ruby. MultiJson does not honor the escape_mode parameter to escape fields as an XSS protection mechanism. To mitigate, json_dumper.rb in gon now does escaping for XSS by default without relying on MultiJson.

CVSS Base Scores

version 3.1