CVE-2021-28834 Affecting ruby-kramdown package, versions <1.17.0-4ubuntu0.2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.7% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-RUBYKRAMDOWN-1122786
  • published10 Oct 2023
  • disclosed19 Mar 2021

Introduced: 19 Mar 2021

CVE-2021-28834  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 ruby-kramdown to version 1.17.0-4ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-kramdown package and not the ruby-kramdown package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Kramdown before 2.3.1 does not restrict Rouge formatters to the Rouge::Formatters namespace, and thus arbitrary classes can be instantiated.

CVSS Base Scores

version 3.1