Inefficient Regular Expression Complexity Affecting ruby-rack package, versions <2.0.7-2ubuntu0.1+esm3


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.63% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-RUBYRACK-3253109
  • published30 Jan 2023
  • disclosed9 Feb 2023

Introduced: 30 Jan 2023

CVE-2022-44570  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 ruby-rack to version 2.0.7-2ubuntu0.1+esm3 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby-rack package and not the ruby-rack package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A denial of service vulnerability in the Range header parsing component of Rack >= 1.5.0. A Carefully crafted input can cause the Range header parsing component in Rack to take an unexpected amount of time, possibly resulting in a denial of service attack vector. Any applications that deal with Range requests (such as streaming applications, or applications that serve files) may be impacted.

CVSS Base Scores

version 3.1