Out-of-bounds Write Affecting sane-backends package, versions <1.0.29-0ubuntu5.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.04% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-SANEBACKENDS-608119
  • published23 May 2020
  • disclosed24 Jun 2020

Introduced: 23 May 2020

CVE-2020-12861  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 sane-backends to version 1.0.29-0ubuntu5.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream sane-backends package and not the sane-backends package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A heap buffer overflow in SANE Backends before 1.0.30 allows a malicious device connected to the same local network as the victim to execute arbitrary code, aka GHSL-2020-080.

CVSS Base Scores

version 3.1