Arbitrary Code Injection Affecting smarty3 package, versions <3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
82.32% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-SMARTY3-1123373
  • published14 Feb 2022
  • disclosed22 Feb 2021

Introduced: 22 Feb 2021

CVE-2021-26120  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 smarty3 to version 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream smarty3 package and not the smarty3 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Smarty before 3.1.39 allows code injection via an unexpected function name after a {function name= substring.

CVSS Base Scores

version 3.1