Race Condition Affecting spice-vdagent package, versions <0.19.0-2ubuntu0.2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.33% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-SPICEVDAGENT-1035857
  • published4 Nov 2020
  • disclosed26 Nov 2020

Introduced: 4 Nov 2020

CVE-2020-25653  (opens in a new tab)
CWE-362  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 spice-vdagent to version 0.19.0-2ubuntu0.2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spice-vdagent package and not the spice-vdagent package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

A race condition vulnerability was found in the way the spice-vdagentd daemon handled new client connections. This flaw may allow an unprivileged local guest user to become the active agent for spice-vdagentd, possibly resulting in a denial of service or information leakage from the host. The highest threat from this vulnerability is to data confidentiality as well as system availability. This flaw affects spice-vdagent versions 0.20 and prior.

CVSS Base Scores

version 3.1