Use After Free Affecting tidy-html5 package, versions <2:5.6.0-11ubuntu0.20.04.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.13% (63rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-TIDYHTML5-3358857
  • published14 Mar 2023
  • disclosed17 Feb 2023

Introduced: 17 Feb 2023

CVE-2021-33391  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 tidy-html5 to version 2:5.6.0-11ubuntu0.20.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tidy-html5 package and not the tidy-html5 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

An issue in HTACG HTML Tidy v5.7.28 allows attacker to execute arbitrary code via the -g option of the CleanNode() function in gdoc.c.

CVSS Base Scores

version 3.1