Improper Certificate Validation Affecting tigervnc package, versions <1.10.1+dfsg-3ubuntu0.1+esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.06% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-TIGERVNC-1135824
  • published21 Mar 2026
  • disclosed27 Sept 2020

Introduced: 27 Sep 2020

CVE-2020-26117  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 tigervnc to version 1.10.1+dfsg-3ubuntu0.1+esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream tigervnc package and not the tigervnc package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In rfb/CSecurityTLS.cxx and rfb/CSecurityTLS.java in TigerVNC before 1.11.0, viewers mishandle TLS certificate exceptions. They store the certificates as authorities, meaning that the owner of a certificate could impersonate any server after a client had added an exception.

CVSS Base Scores

version 3.1