Out-of-Bounds Affecting valgrind package, versions <1:3.12.0-1.1ubuntu2


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.77% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-VALGRIND-582770
  • published24 Feb 2017
  • disclosed24 Feb 2017

Introduced: 24 Feb 2017

CVE-2016-4491  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 valgrind to version 1:3.12.0-1.1ubuntu2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream valgrind package and not the valgrind package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

The d_print_comp function in cp-demangle.c in libiberty allows remote attackers to cause a denial of service (segmentation fault and crash) via a crafted binary, which triggers infinite recursion and a buffer overflow, related to a node having "itself as ancestor more than once."