Improper Input Validation Affecting varnish package, versions <6.2.1-2ubuntu0.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.16% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-VARNISH-1147641
  • published1 Nov 2020
  • disclosed8 Apr 2020

Introduced: 8 Apr 2020

CVE-2020-11653  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 varnish to version 6.2.1-2ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream varnish package and not the varnish package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

An issue was discovered in Varnish Cache before 6.0.6 LTS, 6.1.x and 6.2.x before 6.2.3, and 6.3.x before 6.3.2. It occurs when communication with a TLS termination proxy uses PROXY version 2. There can be an assertion failure and daemon restart, which causes a performance loss.

CVSS Base Scores

version 3.1