Directory Traversal Affecting vim package, versions <2:8.1.2269-1ubuntu5.32+esm9


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.13% (3rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-VIM-15978831
  • published1 Jul 2026
  • disclosed6 Apr 2026

Introduced: 6 Apr 2026

CVE-2026-35177  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 vim to version 2:8.1.2269-1ubuntu5.32+esm9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vim package and not the vim package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

Vim is an open source, command line text editor. Prior to 9.2.0280, a path traversal bypass in Vim's zip.vim plugin allows overwriting of arbitrary files when opening specially crafted zip archives, circumventing the previous fix for CVE-2025-53906. This vulnerability is fixed in 9.2.0280.

CVSS Base Scores

version 3.1