Improper Certificate Validation Affecting vsftpd package, versions <3.0.5-0ubuntu0.20.04.1


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.03% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-VSFTPD-1536629
  • published4 Aug 2021
  • disclosed23 Mar 2022

Introduced: 4 Aug 2021

CVE-2021-3618  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 vsftpd to version 3.0.5-0ubuntu0.20.04.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream vsftpd package and not the vsftpd package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

ALPACA is an application layer protocol content confusion attack, exploiting TLS servers implementing different protocols but using compatible certificates, such as multi-domain or wildcard certificates. A MiTM attacker having access to victim's traffic at the TCP/IP layer can redirect traffic from one subdomain to another, resulting in a valid TLS session. This breaks the authentication of TLS and cross-protocol attacks may be possible where the behavior of one protocol service may compromise the other at the application layer.

CVSS Base Scores

version 3.1