Memory Leak Affecting whoopsie package, versions <0.2.69ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.47% (37th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-WHOOPSIE-597250
  • published4 Aug 2020
  • disclosed6 Aug 2020

Introduced: 4 Aug 2020

CVE-2020-11937  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 whoopsie to version 0.2.69ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream whoopsie package and not the whoopsie package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In whoopsie, parse_report() from whoopsie.c allows a local attacker to cause a denial of service via a crafted file. The DoS is caused by resource exhaustion due to a memory leak. Fixed in 0.2.52.5ubuntu0.5, 0.2.62ubuntu0.5 and 0.2.69ubuntu0.1.

CVSS Base Scores

version 3.1