CVE-2024-39844 Affecting znc package, versions <1.7.5-4ubuntu0.1~esm2


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
3.86% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2004-ZNC-7421285
  • published5 Sept 2024
  • disclosed3 Jul 2024

Introduced: 3 Jul 2024

CVE-2024-39844  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.04 znc to version 1.7.5-4ubuntu0.1~esm2 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream znc package and not the znc package as distributed by Ubuntu. See How to fix? for Ubuntu:20.04 relevant fixed versions and status.

In ZNC before 1.9.1, remote code execution can occur in modtcl via a KICK.