Arbitrary Command Injection The advisory has been revoked - it doesn't affect any version of package cimg  (opens in a new tab)


Threat Intelligence

EPSS
4.97% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-CIMG-1031604
  • published25 Jul 2019
  • disclosed25 Jul 2019

Introduced: 25 Jul 2019

CVE-2019-1010174  (opens in a new tab)
CWE-77  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:20.10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cimg package and not the cimg package as distributed by Ubuntu.

CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.