Out-of-Bounds Affecting lua5.4 package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.09% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-LUA54-1029591
  • published10 Sept 2020
  • disclosed13 Aug 2020

Introduced: 13 Aug 2020

CVE-2020-24342  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.10 lua5.4.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua5.4 package and not the lua5.4 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

Lua through 5.4.0 allows a stack redzone cross in luaO_pushvfstring because a protection mechanism wrongly calls luaD_callnoyield twice in a row.

CVSS Base Scores

version 3.1