OS Command Injection Affecting mariadb-10.3 package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
38.44% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-MARIADB103-1087816
  • published20 Mar 2021
  • disclosed19 Mar 2021

Introduced: 19 Mar 2021

CVE-2021-27928  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.10 mariadb-10.3.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-10.3 package and not the mariadb-10.3 package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

A remote code execution issue was discovered in MariaDB 10.2 before 10.2.37, 10.3 before 10.3.28, 10.4 before 10.4.18, and 10.5 before 10.5.9; Percona Server through 2021-03-03; and the wsrep patch through 2021-03-03 for MySQL. An untrusted search path leads to eval injection, in which a database SUPER user can execute OS commands after modifying wsrep_provider and wsrep_notify_cmd. NOTE: this does not affect an Oracle product.

CVSS Base Scores

version 3.1