Improper Input Validation Affecting network-manager package, versions <1.26.2-1ubuntu1.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.26% (18th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-NETWORKMANAGER-1090548
  • published2 Apr 2021
  • disclosed26 May 2021

Introduced: 2 Apr 2021

CVE-2021-20297  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.10 network-manager to version 1.26.2-1ubuntu1.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream network-manager package and not the network-manager package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

A flaw was found in NetworkManager in versions before 1.30.0. Setting match.path and activating a profile crashes NetworkManager. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1