Improper Input Validation Affecting node-merge package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.68% (74th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-NODEMERGE-1032475
  • published4 May 2020
  • disclosed30 Oct 2018

Introduced: 30 Oct 2018

CVE-2018-16469  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.10 node-merge.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-merge package and not the node-merge package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

The merge.recursive function in the merge package <1.2.1 can be tricked into adding or modifying properties of the Object prototype. These properties will be present on all objects allowing for a denial of service attack.

CVSS Base Scores

version 3.1