Arbitrary Code Injection Affecting node-nodemailer package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.3% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-NODENODEMAILER-1039839
  • published13 Nov 2020
  • disclosed12 Nov 2020

Introduced: 12 Nov 2020

CVE-2020-7769  (opens in a new tab)
CWE-74  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.10 node-nodemailer.

NVD Description

Note: Versions mentioned in the description apply only to the upstream node-nodemailer package and not the node-nodemailer package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

This affects the package nodemailer before 6.4.16. Use of crafted recipient email addresses may result in arbitrary command flag injection in sendmail transport for sending mails.

CVSS Base Scores

version 3.1