Cross-site Scripting (XSS) The advisory has been revoked - it doesn't affect any version of package nomad  (opens in a new tab)


Threat Intelligence

EPSS
0.67% (47th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-NOMAD-1030021
  • published1 Nov 2020
  • disclosed28 Apr 2020

Introduced: 28 Apr 2020

CVE-2020-10944  (opens in a new tab)
CWE-79  (opens in a new tab)

Amendment

The Ubuntu security team deemed this advisory irrelevant for Ubuntu:20.10.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nomad package and not the nomad package as distributed by Ubuntu.

HashiCorp Nomad and Nomad Enterprise up to 0.10.4 contained a cross-site scripting vulnerability such that files from a malicious workload could cause arbitrary JavaScript to execute in the web UI. Fixed in 0.10.5.