Improper Verification of Cryptographic Signature Affecting rpm package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.65% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-RPM-1086092
  • published16 Mar 2021
  • disclosed19 May 2021

Introduced: 16 Mar 2021

CVE-2021-3421  (opens in a new tab)
CWE-347  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.10 rpm.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm package and not the rpm package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

A flaw was found in the RPM package in the read functionality. This flaw allows an attacker who can convince a victim to install a seemingly verifiable package or compromise an RPM repository, to cause RPM database corruption. The highest threat from this vulnerability is to data integrity. This flaw affects RPM versions before 4.17.0-alpha.

CVSS Base Scores

version 3.1