CVE-2021-31215 Affecting slurm-llnl package, versions *


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.9% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-SLURMLLNL-1292279
  • published14 May 2021
  • disclosed13 May 2021

Introduced: 13 May 2021

CVE-2021-31215  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:20.10 slurm-llnl.

NVD Description

Note: Versions mentioned in the description apply only to the upstream slurm-llnl package and not the slurm-llnl package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

SchedMD Slurm before 20.02.7 and 20.03.x through 20.11.x before 20.11.7 allows remote code execution as SlurmUser because use of a PrologSlurmctld or EpilogSlurmctld script leads to environment mishandling.

CVSS Base Scores

version 3.1