Out-of-bounds Write Affecting wavpack package, versions <5.3.0-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.21% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2010-WAVPACK-1055676
  • published5 Jan 2021
  • disclosed28 Dec 2020

Introduced: 28 Dec 2020

CVE-2020-35738  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Ubuntu:20.10 wavpack to version 5.3.0-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream wavpack package and not the wavpack package as distributed by Ubuntu. See How to fix? for Ubuntu:20.10 relevant fixed versions and status.

WavPack 5.3.0 has an out-of-bounds write in WavpackPackSamples in pack_utils.c because of an integer overflow in a malloc argument. NOTE: some third-parties claim that there are later "unofficial" releases through 5.3.2, which are also affected.

CVSS Base Scores

version 3.1