Improper Certificate Validation Affecting grilo package, versions <0.3.13-1ubuntu0.1


Severity

Recommended
0.0
medium
0
10

Based on Ubuntu security rating.

Threat Intelligence

EPSS
0.87% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2104-GRILO-1570348
  • published27 Aug 2021
  • disclosed22 Aug 2021

Introduced: 22 Aug 2021

CVE-2021-39365  (opens in a new tab)
CWE-295  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.04 grilo to version 0.3.13-1ubuntu0.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grilo package and not the grilo package as distributed by Ubuntu. See How to fix? for Ubuntu:21.04 relevant fixed versions and status.

In GNOME grilo though 0.3.13, grl-net-wc.c does not enable TLS certificate verification on the SoupSessionAsync objects it creates, leaving users vulnerable to network MITM attacks. NOTE: this is similar to CVE-2016-20011.

CVSS Base Scores

version 3.1