Resource Exhaustion Affecting privoxy package, versions *


Severity

Recommended
low

Based on Ubuntu security rating.

Threat Intelligence

EPSS
2.28% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2104-PRIVOXY-1257324
  • published16 Mar 2021
  • disclosed25 Mar 2021

Introduced: 16 Mar 2021

CVE-2021-20216  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

There is no fixed version for Ubuntu:21.04 privoxy.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Ubuntu. See How to fix? for Ubuntu:21.04 relevant fixed versions and status.

A flaw was found in Privoxy in versions before 3.0.31. A memory leak that occurs when decompression fails unexpectedly may lead to a denial of service. The highest threat from this vulnerability is to system availability.

CVSS Base Scores

version 3.1