Out-of-Bounds Affecting libcaca package, versions <0.99.beta19-2.2ubuntu2.1


Severity

Recommended
medium

Based on Ubuntu security rating.

Threat Intelligence

EPSS
1.35% (70th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-UBUNTU2110-LIBCACA-1736706
  • published15 Apr 2021
  • disclosed26 May 2021

Introduced: 15 Apr 2021

CVE-2021-30498  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Ubuntu:21.10 libcaca to version 0.99.beta19-2.2ubuntu2.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libcaca package and not the libcaca package as distributed by Ubuntu. See How to fix? for Ubuntu:21.10 relevant fixed versions and status.

A flaw was found in libcaca. A heap buffer overflow in export.c in function export_tga might lead to memory corruption and other potential consequences.

CVSS Base Scores

version 3.1